Ubuntu 20.04.2 LTS サーバーをインストールしてみる

サーバーOSをインストールしてみました。Cent OS、Debian、Manjaroも最近ちょっとさわってみましたが、最近の情報量が多く、他で触る予定もあるUbuntuにしてみました。

ネットワークケーブルが届くところにないので、アマゾンで買ったTP-LinkのWIFIドングルをUSBにさしています。

Server OSのインストール

https://ubuntu.com/download/server

サーバー用ファイルをダウンロードしてきて、インストールメディアを作成します。DVDドライブがあればインストール用起動DVDメディアを作ればよいですが、ないので、USBフラッシュドライブに書き込みます。

DVDと異なりファイルを入れただけでは起動できないので、Rufusを使って書き込みしました。

https://rufus.ie/ja/

英語を選び、ネットワークはとりあえずなしでセットアップします。最近のデスクトップ用OSよりはだいぶめんどくさいですね。

WIFI設定

ETHERNETケーブルを利用して使うのが最終形態ではありますが、とりあえず作業環境近くにはLAN差し口がないのでWIFIにします。

デスクトップOSのプラグアンドプレイに慣れすぎてつらい・・。

必要パッケージインストール

https://medium.com/@yping88/how-to-enable-wi-fi-on-ubuntu-server-20-04-without-a-wired-ethernet-connection-42e0b71ca198 https://qiita.com/sasayabaku/items/aca8f94faadae5bd32c5

このページの記載にしたがって、別のPCでインストールファイルをダウンロードしてUSBフラッシュメモリからインストールします。

sudo fdisk -f
sudo fdisk -l

-fオプションは誤植なのかバージョンの違いなのか知りませんが、-lオプションでした。パソコンに複数のHDD/SSDがついているせいか、USBメモリは/dev/sdbではなく/dev/sddでした。

sudo mkdir /media/usb
sudo mount -t vfat /dev/sdd1 /media/usb
cd /media/usb
sudo dpkg -i libnl-route-3–200_3.4.0–1_amd64.deb \   
 libpcsclite1_1.8.26–3_amd64.deb \
 wpasupplicant_2.9–1ubuntu4_amd64.deb
umount /media/usb

WIFIポート設定

ls /sys/class/net

をすると、3つ表示されました。

  • eno
  • lo
  • wlxd037450f7380

enoはEthernet on-board、loはloopbackのことなので、WIFI用デバイスはwlxd何某ですね。

https://eng-memo.info/blog/netplan/

SSIDはダブルクォーテーションはなし、パスワードは””で囲みました。dhcp: true, optional: trueで、最後の行のrenderer:は何も書かれてなかったのでとりあえず無視で。

sudo netplan --debug generate
sudo netplan apply
sudo reboot

not for usと言われたけれどエラーは出なかったのでそのままに・・・。

A start job is running for Wait for Network to be Configured

で2分近く待ちましたが、動きました。

gateway4とnameservers

これだけだとapt installでパッケージ情報はみえましたが

 Temporary failure resolving ‘archive.ubuntu.com’

で進みません。

gatewayとnameserversも設定しました。が、動きません。

ドライバー?あきらめ。

確か、Manjaroでは差し込んだだけで使えたTP-Linkのドングルですが、ひょっとしたらドライバーが入っていないのかも・・・。

だいぶ前の購入履歴ですが、アマゾンで探したら「TL-WN725N」でした。メーカーウェブサイトを見に行くと・・

ソースコードをダウンロードしてコンパイルせよと。gccも入っておりません。面倒なのでパス・・・。対応バージョンもLinux (kernel 2.6.18 ~ 4.4.3)で、Ubuntu 20.4のカーネルは5番台・・・。

https://community.tp-link.com/en/home/forum/topic/233064

Ubuntuでは動作しないのかも・・・。

あきらめてネットワークケーブルを持ってきて接続してアップデートをしてみました。

デスクトップ環境インストール

sudo apt-get -y install xserver-xorg

では、virt-managerが起動しなかったので、

sudo apt-get -y install ubuntu-desktop

をしました。

別のデスクトップ環境を入れることもできるよう。

https://phoenixnap.com/kb/how-to-install-a-gui-on-ubuntu

WIFIが動いた?やっぱりだめ。

デスクトップ環境にしてみたところ、TP-LinkのWIFIが動くようになりました。どのパッケージだったのだろう・・・。

アクセスポイントに接続、接続状態の確認もできました。さらに、アクセスポイント側にも接続されているのを確認できます。が、インターネットへの接続ができない・・・。やっぱりドライバーかも。

シェアする

  • このエントリーをはてなブックマークに追加

フォローする